next up previous contents index
Next: Initial Operations Up: Initialization Files Previous: Initialization Files   Contents   Index

The tbsetup Command

This command can appear in the startup files only. It is inserted into or updated in the .wrspiceinit file in the user's home directory in response to the update command, or from pressing the Update Tools button in the File menu of the Tool Control window. It is not likely that the user will need to work with tbsetup directly, though it can be used to customize the Tools menu in the Tool Control window.

The command string takes the following form:

tbsetup [old] [vert] [toolbar on|off x y] [name1 on|off x y] [name2 ...
The old and vert keywords are ignored. They exist for backward compatibility.

By invoking the update command from the prompt line or pressing the Update Tools button in the File menu of the Tool Control window, a .wrspiceinit file is created in the user's home directory if necessary, and the tbsetup command will be added or updated. This will save the current state of the windows from the Tools menu, which will be recreated when the program is started the next time.

If no tbsetup command is found on program startup, a default configuration is used (all tools initially invisible).

For each argument block in the tbsetup call, the first token gives the tool name, with the ``toolbar'' entry indicating the Tool Control window itself. For other than the Tool Control window, which is always shown, the on and off keywords specify whether the tools are shown at startup. The two numbers that follow give the position of the upper left corner of the tool on the screen (the screen origin is the upper left corner, coordinates are in pixels). For other than the first (Tool Control window) entry, the blocks can be rearranged or deleted. The Tools menu will show only the tools listed, in the order given. Thus, the Tools menu can be customized.

To generate an initial custom configuration, simply start WRspice on a system that supports graphics, and the Tool Control window will appear somewhere on-screen. After opening some of the tools from the Tools menu and arranging them as necessary and/or moving the Tool Control window, the Update Tools button in the File menu can be pressed. A .wrspiceinit file will be created, or an existing file updated, in the user's home directory. Alternatively, the update command can be given from the command line. Hand editing of the .wrspiceinit file may be used to remove buttons or change the button order in the Tools menu. Once edited, only the tools present will be updated.


next up previous contents index
Next: Initial Operations Up: Initialization Files Previous: Initialization Files   Contents   Index
Stephen R. Whiteley 2017-02-22