next up previous contents index
Next: Cell Hierarchy and geometry Up: The File Menu: Xic Previous: The Format Menu: Hardcopy   Contents   Index

The Files List Button: Path Files Listing Panel

The Path Files Listing panel lists the layout files found along the search path, including the files found through redirect files. The panel can be used to open files and cells for editing and placement, among other useful features. The file is brought up with the Files List button in the File Menu.

The panel contains a drop-down menu which has an entry for each directory in the search path, and each directory referenced in a redirect file. The main text area lists the files found in the currently selected directory.

File names are listed in columns. A character specifies the file type: ``X'' for Xic, ``B'' for CGX, ``C'' for CIF, ``G'' for GDSII, ``O'' for OASIS, and ``L'' for library files. Unrecognized file types are not listed. The directories are polled periodically, and the file listing is refreshed when changes are found. Unfortunately, this is not available under Windows 95/98/ME. In that case, resizing the window or popping the listing down then up again will refresh the listing.

The text area of the files listing is a drag and drop source and receiver. As a receiver, files or directories dropped in this area will appear in the directory that contains the listed files. By default, a confirmation pop-up will appear before any action occurs, but experienced users can disable this by setting the NoAskFileAction variable. See the description of the File Selection panel in 8.2.5 for the operations that can be performed via drag/drop. File names from the listing can be dragged into the drawing windows, which will load the file into the window.

A file can be selected by clicking on the name, and while selected it will be highlighted. When a file name is selected, the Open, Place, and Contents command buttons become active. These buttons are inactive (grayed) unless a file name is selected.

With a file name selected, pressing the Open button will load the file into the main window, as if the file was opened with the Open command in the File Menu. If the file is a library or has multiple top-level cells, a window appears which enables the user to make a selection to resolve the ambiguity. If the current cell is modified, the user will be given the opportunity to save it before switching to the new cell.

Similarly, pressing the Place button will load the top-level cell (after ambiguity resolution, if necessary) into the Cell Placement Control panel, from which it can be instantiated.

The Contents button brings up a panel which displays a listing of the cells found in the currently selected archive file, or a list of references if the selected file is a library. This button is enabled only when the selected file name corresponds to an archive or library (codes B, C, G, O, or L). The Contents button makes it possible to extract individual cells and subcells from an archive file, without having to load the whole file. It also provides access to the references contained within a library file.

The contents listing window contains Open and Place buttons. These buttons are normally grayed, but become active when a name is selected in the contents listing. Names are selecting by clicking with the mouse, as in the Path Files Listing panel.

Pressing the Open button will extract the named cell from the source file or library, along with its hierarchy, and load it into the main window. If the current cell is modified, the user will be given the opportunity to save it before switching to the new cell.

Similarly, pressing the Place button will load the selected cell into the Cell Placement Control panel, from which it can be instantiated.

The contents listing is a drag source for drag/drop. Names from the list can be dropped into a drawing window, with an effect similar to using the Open button. If a cell name from the contents list is dragged and dropped into a drawing window, that cell and its descendents will be extracted from the archive and displayed in the window.

When Xic is in CHD display mode, i.e., the Display button in the Cell Hierarchy Digests panel is active, the Open and Place buttons in the Path Files Listing and the contents window are not available. The Place buttons are not available in the Xiv feature set.


next up previous contents index
Next: Cell Hierarchy and geometry Up: The File Menu: Xic Previous: The Format Menu: Hardcopy   Contents   Index
Stephen R. Whiteley 2017-10-02