next up previous contents index
Next: The Info Button: Display Up: The View Menu: Alter Previous: The Cross Section Button:   Contents   Index


The Rulers Button: Create Rulers

The Rulers button in the View Menu provides a facility for creating rulers. Rulers, available in physical mode, are visible calibrated gradations which indicate physical distance in microns. Rulers are often convenient for measuring distances, and in hard copies to indicate size scale.

When the Rulers button is on, rulers can be created by clicking twice at the endpoints of the ruler, or by pressing and dragging, where the ruler will extend from the press and release points. The ruler will only be visible in the window where the first button press occurred, and only rulers in the main window will be visible in hard copies. Rulers can be created in any physical-mode window, including cross-section and cell hierarchy digest displays.

The computed distance between endpoints of the ruler is printed in the prompt area after a ruler is created. This can be used to accurately measure the distance between two points.

Rulers remain visible until another cell is edited, or until deleted. The rulers in effect for a certain cell are remembered, so that upon returning to a previously edited cell, the rulers previously in effect will be visible.

Presently, rulers exist only in memory, and are not saved to disk with cell data.

Rulers can be deleted, while the Rulers button is on, by pressing the Delete or Tab (undo) keys, and are deleted in reverse order of creation, but only in the window that has keyboard focus.. Rulers associated with the current cell can be deleted at any time with the !dr command.

When a ruler is being created, the ghost-drawn vector which appears when creating a ruler indicates the side which will have the gradations. The side with the gradations can be toggled by pressing the `/' or ` \ ' keys.

If Shift is pressed during completion of a ruler, the endpoint will be the start point of a new ruler, and the calibration in the new ruler will be an extension of that in the current ruler. Thus rulers can be ``chained'' around an object to measure the periphery.

If the Constrain angles to 45 degree multiples check box in the Editing Setup panel from the Edit Menu is checked, the angle is constrained to multiples of 45 degrees. If not checked, the angle is unconstrained, but snaps to multiples of 45 degrees when the angle is close. In either case, pressing the Ctrl key removes the constraint.

By default, the tiny snap-box near the mouse pointer, where ruler endpoints can be placed, is constrained to the current snap grid, as is true elsewhere in Xic. The period ('.') key toggles snapping to grid points while in the Rulers command. When not snapping, the snap box follows the mouse pointer, allowing per-pixel resolution.

Additionally, if the window shows a normal layout (not CHD or cross section) the endpoints will by default snap to nearby edges and vertices. This is the same edge snapping as is controlled from the Edge Snapping group in the Snapping page of the Grid Setup panel (pressing Ctrl-g will produce this panel). However, the Rulers command has its own defaults, which are active while the Rulers command is active. The default is to allow off-grid locations, and non-Manhattan edges, and to snap to both edges and the path (central spine) of wires. Any of these settings can be changed, and edge snapping disabled, from the Grid Setup panel. Changes will apply only in the Rulers command. Edge snapping applies whether or not grid snapping is enabled.


next up previous contents index
Next: The Info Button: Display Up: The View Menu: Alter Previous: The Cross Section Button:   Contents   Index
Stephen R. Whiteley 2017-11-08