next up previous contents index
Next: Semiconductor Devices Up: Electrical Schematic Editing Previous: Electrical Schematic Editing   Contents   Index


Placement of Devices and Subcircuits

Xic is distributed with a representative device library, which is contained in a file named device.lib found in the installation startup directory. This contains most if not all of the devices supported by WRspice, however it may be necessary to customize this file to the user's unique requirements. The format of this file is described in the appendix. The devices found in the device library file are those listed in the device menu, which is available while in electrical mode.

Devices can also be supplied in cell files, or from an OpenAccess database. For example, it is feasible to use devices from the analogLib library from a Virtuoso installation, or from a foundry design kit.

Xic usually starts in physical mode, though if given the -E option on the command line Xic will start in electrical mode. To switch from physical to electrical mode, press the Electrical button in the View Menu. Xic will reconfigure the side menu, and display the schematic for the current cell (if any). Pressing the devs button in the side menu will bring up a device menu which extends across the top of the main Xic window. There are two styles of device menu available. The default menu consists of an array of lettered buttons. Pressing button 1 while the pointer is over one of these buttons will cause a drop-down menu to appear, which consists of more buttons containing device names. The first letter of these devices is that on the original button. A device can be selected by releasing button 1 while the pointer is over the desired button.

A second device menu style consists of panels containing the names and schematic symbols of the various devices with perhaps a button with a right-pointing arrow, if the selections do not entirely fit on-screen. Clicking on the arrow button will show the devices which did not fit in the initial menu. This menu has the disadvantage of occupying a lot of screen space, but it may be easier for new users.

Both menu styles contain a button that switches to the other style of menu. The present style will be used until changed by the user. The style used is completely arbitrary, and simply a user-preference.

Clicking on one of the device panels in the pictorial menu, or releasing button 1 on a selection in the pull-down menu will attach the schematic symbol to the mouse pointer. Then clicking in the drawing window will leave instances of that device at those locations. Press Esc to exit this mode. This is the means by which devices are added to the circuit. New devices can also be produced by using a copy operation (a button 1 operation, or explicitly using the Copy command in the Modify Menu) from an existing device in the circuit.

The user may have already designed one or more circuits using Xic, which are then available for use as subcircuits in the present schematic. The details of how to create a ``true'' subcircuit will be presented shortly; for now, assume that such cells already exist. Subcircuits are called and placed with the place command in the side menu, in the same manner as subcells in physical mode. After pressing the place button, the Cell Placement Control pop-up will appear, which allows the user to select a cell to place from cells that have been placed previously, or to enter a new cell name to place. The cell name can be dragged from the File Selection panel or from the List pop-ups in the File Menu. In addition, the List pop-ups contain a Place button which will also set the name of the current ``master'' cell to be placed, and pop up the Cell Placement Control pop-up if it is not already visible. When the Place button in the Cell Placement Control pop-up is active, the current ``master'' will be ``attached'' to the mouse pointer, and instances will be placed at locations where the user clicks with mouse button 1 in the drawing. The placement mode can be exited by pressing the Esc key, or by unsetting the Place button in the Cell Placement Control pop-up.

Once devices and subcircuits have been placed in the drawing, they can be moved and copied as for physical cells. Not all of the transformations of physical mode are available, however, from the xform command in the side menu. Specifically, rotations are limited to multiples of 90 degrees, and there is no magnification capability.


next up previous contents index
Next: Semiconductor Devices Up: Electrical Schematic Editing Previous: Electrical Schematic Editing   Contents   Index
Stephen R. Whiteley 2017-03-22