next up previous contents index
Next: The View Menu: Alter Up: The Modify Menu: Modify Previous: The Change Layer Button:   Contents   Index


The Set Layer Chg Mode Button: Set Change Mode for Move/Copy

This button brings up a panel which sets the layer change mode that applies to all move and copy operations, and to the spin command in the physical side menu. In these commands, when objects being moved or copied are ghost drawn as attached to the mouse pointer, it is possible to change the current layer. The operation is then completed by clicking at the new location in a drawing window.

The Layer Change Mode pop-up contains three ``radio'' buttons, which determine the response to the mid-command layer change.

Don't allow layer change
The layer change is simply ignored as it relates to the move/copy operation in progress. This is the default.

Allow layer change for objects on current layer
Any of the objects being moved/copied that are on the previous current layer will be moved or copied to the new current layer. Other objects are moved/copied normally.

Allow layer change for all objects
All objects will be moved or copied to the new layer.

The pop-up sets and tracks the state of the LayerChangeMode variable.

This is a tri-state variable. If not set, there will be no layer change in these commands. If set to the string ``all'' (case insensitive), then a layer change will apply to all objects being moved or copied. If set to anything else, including to nothing (i.e., as a boolean) then only objects on the previous current layer will be changed to the new layer.


next up previous contents index
Next: The View Menu: Alter Up: The Modify Menu: Modify Previous: The Change Layer Button:   Contents   Index
Stephen R. Whiteley 2017-04-09